Whenever I opens some web link which is hosted on server

Having problems with building or using the JCEF Java binding? Ask your questions here.

Whenever I opens some web link which is hosted on server

Postby battalian » Tue Mar 13, 2018 8:05 am

Code: Select all
24bdf6a4 55b07bbd e0000008 00000001 00000001 KERNELBASE!RaiseException+0x58
24bdf6c0 55b07b9a 216eb000 24bdf764 5506ffa0 chrome_child!base::`anonymous namespace'::OnNoMemory+0x1d [C:\b\c\b\win_clang\src\base\process\memory_win.cc @ 44]
24bdf6cc 5506ffa0 216eb000 54a2d3dc 24bdf6d8 chrome_child!base::TerminateBecauseOutOfMemory+0xa [C:\b\c\b\win_clang\src\base\process\memory_win.cc @ 53]
24bdf764 5506facd 24bdf79c 216eb000 0000003e chrome_child!discardable_memory::ClientDiscardableSharedMemoryManager::AllocateLockedDiscardableSharedMemory+0x19e [C:\b\c\b\win_clang\src\components\discardable_memory\client\client_discardable_shared_memory_manager.cc @ 373]
24bdf7b0 56403990 24bdf808 216eac00 c40b8000 chrome_child!discardable_memory::ClientDiscardableSharedMemoryManager::AllocateLockedDiscardableMemory+0x207 [C:\b\c\b\win_clang\src\components\discardable_memory\client\client_discardable_shared_memory_manager.cc @ 212]
24bdf824 564032f2 24bdf910 24bdfa18 24bdfab0 chrome_child!cc::SoftwareImageDecodeCache::GetExactSizeImageDecode+0x90 [C:\b\c\b\win_clang\src\cc\tiles\software_image_decode_cache.cc @ 605]
24bdf8b4 56404777 24bdf910 24bdfa18 24bdfab0 chrome_child!cc::SoftwareImageDecodeCache::DecodeImageInternal+0x1b2 [C:\b\c\b\win_clang\src\cc\tiles\software_image_decode_cache.cc @ 477]
24bdf94c 56403e13 24bdf9cc 24bdfa18 24bdfab0 chrome_child!cc::SoftwareImageDecodeCache::GetDecodedImageForDrawInternal+0x327 [C:\b\c\b\win_clang\src\cc\tiles\software_image_decode_cache.cc @ 548]
24bdfb9c 564032de 24bdfca0 050ca638 050ca6d0 chrome_child!cc::SoftwareImageDecodeCache::GetScaledImageDecode+0x1c3 [C:\b\c\b\win_clang\src\cc\tiles\software_image_decode_cache.cc @ 728]
24bdfc2c 56402dfe 24bdfca0 050ca638 050ca6d0 chrome_child!cc::SoftwareImageDecodeCache::DecodeImageInternal+0x19e [C:\b\c\b\win_clang\src\cc\tiles\software_image_decode_cache.cc @ 479]
24bdfcd4 564068c0 050ca638 050ca6d0 00000000 chrome_child!cc::SoftwareImageDecodeCache::DecodeImage+0x10e [C:\b\c\b\win_clang\src\cc\tiles\software_image_decode_cache.cc @ 408]
24bdfd48 54d711bc 030a8a64 030a8a48 050ca610 chrome_child!cc::`anonymous namespace'::SoftwareImageDecodeTaskImpl::RunOnWorkerThread+0x70 [C:\b\c\b\win_clang\src\cc\tiles\software_image_decode_cache.cc @ 119]
24bdfd98 54add477 00000001 030a8a48 0311111c chrome_child!content::CategorizedWorkerPool::RunTaskInCategoryWithLockAcquired+0x6a [C:\b\c\b\win_clang\src\content\renderer\categorized_worker_pool.cc @ 361]
24bdfdb0 54add417 0311111c 030a8a60 031110c8 chrome_child!content::CategorizedWorkerPool::RunTaskWithLockAcquired+0x39 [C:\b\c\b\win_clang\src\content\renderer\categorized_worker_pool.cc @ 340]
24bdfdcc 56ae5d06 0311111c 030a8ab0 24bdfe30 chrome_child!content::CategorizedWorkerPool::Run+0x2b [C:\b\c\b\win_clang\src\content\renderer\categorized_worker_pool.cc @ 232]
24bdfddc 54add371 031110c8 0000001a 00000000 chrome_child!content::`anonymous namespace'::CategorizedWorkerPoolThread::Run+0x14 [C:\b\c\b\win_clang\src\content\renderer\categorized_worker_pool.cc @ 35]
24bdfe30 55af9679 031110c8 000002b8 000002b8 chrome_child!base::SimpleThread::ThreadMain+0x1c1 [C:\b\c\b\win_clang\src\base\threading\simple_thread.cc @ 68]
24bdfe54 774aef8c 03133dc0 24bdfea0 7735367a chrome_child!base::`anonymous namespace'::ThreadFunc+0xb9 [C:\b\c\b\win_clang\src\base\threading\platform_thread_win.cc @ 92]
24bdfe60 7735367a 03133dc0 405b4b08 00000000 kernel32!BaseThreadInitThunk+0xe
24bdfea0 7735364d 55af95c0 03133dc0 ffffffff ntdll!__RtlUserThreadStart+0x70
24bdfeb8 00000000 55af95c0 03133dc0 00000000 ntdll!_RtlUserThreadStart+0x1b



What can be the issue?
Last edited by battalian on Thu Mar 15, 2018 12:41 am, edited 1 time in total.
battalian
Newbie
 
Posts: 4
Joined: Tue Mar 13, 2018 8:00 am

Re: Whenever I opens some web link which is hosted on some o

Postby magreenblatt » Tue Mar 13, 2018 12:56 pm

What OS and CEF version? What steps to reproduce the problem? Does the problem reproduce in cefclient?
magreenblatt
Site Admin
 
Posts: 8590
Joined: Fri May 29, 2009 6:57 pm

Re: Whenever I opens some web link which is hosted on some o

Postby battalian » Tue Mar 13, 2018 1:07 pm

os: windows 8
cef version: 62.0.3178

An application is hosted on server, While exploring that hosted site on my system chrome was getting crashed with that trace.

This error was on client machine. As soon as I get complete information I will update more. But, what leads to that kind of error?
battalian
Newbie
 
Posts: 4
Joined: Tue Mar 13, 2018 8:00 am

Re: Whenever I opens some web link which is hosted on some o

Postby magreenblatt » Tue Mar 13, 2018 1:24 pm

It looks like you're running out of memory while decoding an image. Is it a 32-bit application? If so, build with the /LARGEADDRESSAWARE flag.
magreenblatt
Site Admin
 
Posts: 8590
Joined: Fri May 29, 2009 6:57 pm

Re: Whenever I opens some web link which is hosted on some o

Postby battalian » Wed Mar 14, 2018 12:59 am

I searched over internet, There are ways to set LARGEADRESSAWARE flag from Visual studio(c, c++ applications) but we were using JAVA in our project.
Do I need to do it through Microsoft Visual Studio command prompt only ??
Is it a flag that should be set whenever I run my application by running .bat file (Do I need to set that flag to the .bat file)?

By the way, that application was hosted on server not on local machine. So, I need to build using that flag on server machine?
battalian
Newbie
 
Posts: 4
Joined: Tue Mar 13, 2018 8:00 am

Re: Whenever I opens some web link which is hosted on some o

Postby Phylanx » Wed Mar 14, 2018 2:12 am

Hi, battalian!

Do you mean that you are using JCEF?
If so then it would be better to post this topic in the JCEF specific forums.
Maybe an admin could move this?

Like Marshal said, it looks like your native memory is running out.
Are you running a 32 or 64 bit Java process?
Which JVM heap settings are you using (-Xmx, -Xms, -Xss,...)?
If 32 bit, your solution could be using less memory reserved for the java heap (The more Xmx you give the java heap, the less memory is available for the native part).
Phylanx
Mentor
 
Posts: 94
Joined: Thu Aug 11, 2016 8:17 am

Re: Whenever I opens some web link which is hosted on server

Postby battalian » Thu Mar 15, 2018 5:32 am

Hi phylanx,

This error does not seem to have anything to do with java or(JVM), I am just accessing the hosted web link.
In the trace, I can see it is something related to images decoding or size handling by chrome browser. But the strange thing is that for the same images chrome works fine sometimes and in other browsers it always work fine.
Is there an issue related to images handling in chrome ?

[u]System Configuration:
32 BIT
Windows 2008
3GB RAM

Actually I am using is Virtual machine.
battalian
Newbie
 
Posts: 4
Joined: Tue Mar 13, 2018 8:00 am

Re: Whenever I opens some web link which is hosted on server

Postby Phylanx » Thu Mar 15, 2018 9:03 am

Hi!

Java might not be the reason for the massive use of memory for rendering this picture, but it enforces problems with memory.
A normal 32 bit process in windows can allocate 2 or 4 GB of memory which can all be used by the application (e.g. Chrome).

If you use a 32 bit Java application, a big part of the memory is reserved for the Java Objects (java heap).
Depending on your -Xmx setting, this might be up to 1278k, which would leave only a small part of the memory for JCEF.

Another problem with this is:
If the failing memory allocation for the image rendering needs e.g. 100MB memory and this memory amount can't be allocated in one block, it also fails, even if two sections with 70MB would be available.

So yes, maybe Chromium or its image rendering component has a bug for using too much memory for rendering that image, but the Java Memory model enforces this problem more than CEF without java.
We had a similar problem with printing PDFs containing ImageMasks or transparent images, see viewtopic.php?f=17&t=14829

By the way, could you please provide an image or link to reproduce the problem?
Phylanx
Mentor
 
Posts: 94
Joined: Thu Aug 11, 2016 8:17 am


Return to JCEF Forum

Who is online

Users browsing this forum: No registered users and 1 guest