Old URL Sent to server

Having problems with building or using the CefGlue .NET/Mono binding? Ask your questions here.

Moderator: fddima

Old URL Sent to server

Postby lifelonglearner » Thu Jun 24, 2021 3:52 am

As I'm new to this forum, please advice if I'm at the wrong end and should post somewhere else.
I'm using CEF# in order to enrich a Win10 native .net application by showing data from a new tool being developed as WebAPP. Now.
In order to ensure there's only one browser open at every point in time, this browser is instatiated as member of a UserControl, which as such is implemented following the singleton pattern.
This singleton object is moved around between parents, depending on where data needs to be visualized, keeping track of the owners by managing its own stack of owners and associated URLs. When the parent ist closed the singleton obejct get's reassigned to its formwer "owner". Works nice under normal circumstances BUT on occasion it happends that a call like
this.myBrowser.Load(this.newURL)

get's received by the Web server as this.lastURL. It looks like somewhere on the way to being transmitted to the server the URL get's replaced by some "old" cached URL (NOT THE SERVER RESPONSE!!!) that was sent to the web server earlier.
I have verified this by Console.WriteLine( this.newURL) and monitoring what's received on the server end. And bingo, URLs don't match.
Any help is very much appreciated.
Update as of 2021-06-30:
As I'm in dire straits to solve this issue I've been debugging this problem step by step for the last days (with other stuff in between, though). Realizing that with certain breakpoints activated the code behaves as expected, which make me believe that it's got something to do with threading.
lifelonglearner
Newbie
 
Posts: 1
Joined: Thu Jun 24, 2021 3:20 am

Return to CefGlue Forum

Who is online

Users browsing this forum: No registered users and 2 guests