Fail to run JCEF on MacOS without a bundle

Having problems with building or using the JCEF Java binding? Ask your questions here.

Fail to run JCEF on MacOS without a bundle

Postby FriwiDev » Mon Nov 09, 2020 11:02 am

Hey there,

I want to invoke JCEF via a java command on MacOS Catalina.

Steps I took:

[*]Downloaded this build from the jcefbuilds (newest version from september): https://github.com/jcefbuild/jcefbuild/ ... 0.4147.105
[*]Launched the bundle successfully to test it out
[*]Then I changed the directory structure as suggested by the following issue (pinned comment): https://bitbucket.org/chromiumembedded/ ... -icudtldat
[*]Created a run.sh in the main directory:

Code: Select all
export LIB_PATH="bin/lib/macos64"
 
java -cp "./bin:./bin/*" -Djava.library.path=$LIB_PATH tests.detailed.MainFrame\
  --framework-dir-path=$LIB_PATH/Chromium\ Embedded\ Framework.framework\
  --main-bundle-path=$LIB_PATH/jcef\ Helper.app\
  --browser-subprocess-path=$LIB_PATH/jcef\ Helper.app/Contents/MacOS/jcef\ Helper\
  --disable-gpu

[*]Then I executed the created script:

Code: Select all
X@Xs-MacBook-Pro macos_jcef_setup % ./run.sh   
Offscreen rendering disabled
Unable to create basic Accelerated OpenGL renderer.
Unable to create basic Accelerated OpenGL renderer.
Core Image is now using the software OpenGL renderer. This will be slow.
WARNING: GL pipe is running in software mode (Renderer ID=0x1020400)
Using:
JCEF Version = 84.3.8.265
CEF Version = 84.3.8
Chromium Version = 84.0.4147.105
AppHandler.stateHasChanged: INITIALIZING
initialize on Thread[AWT-EventQueue-0,6,main] with library path bin/lib/macos64
Added scheme search://
Added scheme client://
./run.sh: line 7:  1400 Trace/BPT trap: 5       java -cp "./bin:./bin/*" -Djava.library.path=$LIB_PATH tests.detailed.MainFrame --framework-dir-path=$LIB_PATH/Chromium\ Embedded\ Framework.framework --main-bundle-path=$LIB_PATH/jcef\ Helper.app --browser-subprocess-path=$LIB_PATH/jcef\ Helper.app/Contents/MacOS/jcef\ Helper --disable-gpu


Tree structure of work dir: https://pastebin.com/raw/1KHRneZW

Crash log: https://pastebin.com/raw/xf8a1NGd

I am pretty much stuck on this, any help or hints would be greatly appreciated. :)
FriwiDev
Newbie
 
Posts: 4
Joined: Sun Jul 09, 2017 4:18 am

Re: Fail to run JCEF on MacOS without a bundle

Postby FriwiDev » Wed Nov 11, 2020 7:50 am

I'm also not required to use this exact structure. So in case anyone has a working example to run on MacOS without a bundle, I'd be glad to be able to test it out.
FriwiDev
Newbie
 
Posts: 4
Joined: Sun Jul 09, 2017 4:18 am

Re: Fail to run JCEF on MacOS without a bundle

Postby FriwiDev » Wed Nov 11, 2020 8:44 am

Update: I also just tested with the release that mentions the official fix, same error:

https://github.com/jcefbuild/jcefbuild/ ... 0.3987.122
FriwiDev
Newbie
 
Posts: 4
Joined: Sun Jul 09, 2017 4:18 am


Return to JCEF Forum

Who is online

Users browsing this forum: No registered users and 3 guests