How to deal with "Failed to launch GPU process on Mac"?

Having problems with building or using the JCEF Java binding? Ask your questions here.

How to deal with "Failed to launch GPU process on Mac"?

Postby StefanLindel » Fri Jan 29, 2021 11:26 am

I want to write a JCef application that embeds the Chromium in a SWT application. When I start it I get the error:

"gpu_process_host.cc(1266)" THE GPU process has crashed x time(x).

I am using a MacOS Catalina 10.15.7
Java 11
CEF 87.1.12+g03f9336+chromium-87.0.4280.88

My Runtime Folder for Chromium:
Code: Select all
./Chromium Embedded Framework
./Libraries
./Libraries/libEGL.dylib
./Libraries/libGLESv2.dylib
./Libraries/libgluegen_rt.dylib
./Libraries/libjcef.dylib
./Libraries/libjogl_desktop.dylib
./Libraries/libjogl_mobile.dylib
./Libraries/libnativewindow_awt.dylib
./Libraries/libnativewindow_macosx.dylib
./Libraries/libnewt_head.dylib
./Libraries/libswiftshader_libEGL.dylib
./Libraries/libswiftshader_libGLESv2.dylib
./Libraries/libvk_swiftshader.dylib
./Libraries/vk_swiftshader_icd.json
./Resources
./Resources/Info.plist
./Resources/de.lproj
./Resources/de.lproj/locale.pak
./Resources/en.lproj
./Resources/en.lproj/locale.pak
./Resources/en_GB.lproj
./Resources/en_GB.lproj/locale.pak
./Resources/icudtl.dat
./cef.pak
./cef_100_percent.pak
./cef_200_percent.pak
./cef_extensions.pak
./chrome_100_percent.pak
./chrome_200_percent.pak
./devtools_resources.pak
./gluegen-rt-natives-macosx-universal.jar
./gluegen-rt.jar
./jcef Helper
./jcef.jar
./jogl-all-natives-macosx-universal.jar
./jogl-all.jar
./junit-platform-console-standalone-1.4.2.jar
./resources.pak
./snapshot_blob.bin
./v8_context_snapshot.x86_64.bin


Is the structure correct? Have I forgotten a library? Or where could be the error?
StefanLindel
Newbie
 
Posts: 2
Joined: Fri Jan 29, 2021 10:36 am

Re: How to deal with "Failed to launch GPU process on Mac"?

Postby magreenblatt » Fri Jan 29, 2021 12:34 pm

magreenblatt
Site Admin
 
Posts: 10938
Joined: Fri May 29, 2009 6:57 pm

Re: How to deal with "Failed to launch GPU process on Mac"?

Postby StefanLindel » Fri Jan 29, 2021 1:05 pm


Thank you for pointing this out. However, I have already seen the post. However, some dylib libraries are missing there and Chromium is not started via the console, but by means of the
https://bitbucket.org/chromiumembedded/java-cef/src/master/java/org/cef/CefApp.java:427

Code: Select all
if (N_Initialize(appHandler_, settings)) setState(CefAppState.INITIALIZED);
StefanLindel
Newbie
 
Posts: 2
Joined: Fri Jan 29, 2021 10:36 am

Re: How to deal with "Failed to launch GPU process on Mac"?

Postby magreenblatt » Fri Jan 29, 2021 2:12 pm

No matter how you start JCEF you still need to create the correct directory structure and pass the correct command-line flags if your structure is not the default app bundle.
magreenblatt
Site Admin
 
Posts: 10938
Joined: Fri May 29, 2009 6:57 pm


Return to JCEF Forum

Who is online

Users browsing this forum: No registered users and 4 guests