Audio is heard when AudioHandler is activated

Having problems with building or using the CefSharp .NET binding? Ask your CEF-related questions here. Please ask general usage questions on StackOverflow.

Moderator: amaitland

Audio is heard when AudioHandler is activated

Postby ValentinNikin » Fri Jul 30, 2021 7:34 am

I came across the following strange problem.
I overrided AudioHandler (I returning "true" from GetAudioParameters and catching buffer in OnAudioStreamPacket).
My application working in Offsreen mode.
When I start application, for a small moment sound is heard in my speaker (maybe 500ms - 1 seconds), then sound is hidden, and all work as expected.
What could be the problem? It seems what CEF does not have time to intercept begin of the sound.
ValentinNikin
Techie
 
Posts: 34
Joined: Fri Jun 18, 2021 1:37 am

Re: Audio is heard when AudioHandler is activated

Postby amaitland » Fri Jul 30, 2021 3:23 pm

Maybe you can workaround the issue by loading a webpage without sound first. Or maybe play a second or two of audio that is inaudible then remove that from your output file.

You'll have to build CEF from source and attach a debugger to find out what's actually going on.
Maintainer of the CefSharp project.
amaitland
Virtuoso
 
Posts: 1011
Joined: Wed Jan 14, 2015 2:35 am

Re: Audio is heard when AudioHandler is activated

Postby ValentinNikin » Fri Jul 30, 2021 4:03 pm

Hm... Ok, I see. Thank you for reply
ValentinNikin
Techie
 
Posts: 34
Joined: Fri Jun 18, 2021 1:37 am

Re: Audio is heard when AudioHandler is activated

Postby amaitland » Fri Jul 30, 2021 4:33 pm

Maintainer of the CefSharp project.
amaitland
Virtuoso
 
Posts: 1011
Joined: Wed Jan 14, 2015 2:35 am


Return to CefSharp Forum

Who is online

Users browsing this forum: No registered users and 1 guest