Custom dictionary is created in current directory

Having problems with building or using CEF's C/C++ APIs? This forum is here to help. Please do not post bug reports or feature requests here.

Custom dictionary is created in current directory

Postby emerick » Thu Jan 18, 2018 10:38 am

When I add a word to the custom dictionary in my app, CEF creates the dictionary file ("Custom Dictionary.txt") in the same directory where my executable lives. This causes problems, because in user installations that directory isn't typically writable. I was expecting the dictionary to follow the same guidelines specified for the user_data_path setting (i.e., use user_data_path if set, or use "Local Settings\Application Data\CEF\User Data" if not set). Am I misunderstanding how this works or does it sound like a bug?
emerick
Expert
 
Posts: 154
Joined: Sun Feb 21, 2010 7:57 pm
Location: Belmont, MA

Re: Custom dictionary is created in current directory

Postby Czarek » Wed Jan 24, 2018 4:38 pm

I also noticed this. Looks like a bug.

Related code sources in Chromium and CEF:
1. https://cs.chromium.org/chromium/src/ch ... e.cc?l=109
2. https://github.com/chromiumembedded/cef ... l.cc#L1061
3. https://github.com/chromiumembedded/cef ... _context.h

Looks like CEF needs to pass a special type of BrowserContext in 2) in which GetPath() method will return user data directory.
Maintainer of the CEF Python, PHP Desktop and CEF C API projects. Connect with me on LinkedIn.
User avatar
Czarek
Virtuoso
 
Posts: 1913
Joined: Sun Nov 06, 2011 2:12 am

Re: Custom dictionary is created in current directory

Postby magreenblatt » Thu Feb 01, 2018 10:08 pm

Please add a bug for this.
magreenblatt
Site Admin
 
Posts: 10939
Joined: Fri May 29, 2009 6:57 pm

Re: Custom dictionary is created in current directory

Postby emerick » Fri Feb 02, 2018 9:00 am

emerick
Expert
 
Posts: 154
Joined: Sun Feb 21, 2010 7:57 pm
Location: Belmont, MA

Re: Custom dictionary is created in current directory

Postby robinm2 » Wed May 12, 2021 11:51 am

Is there any plan to fix this?
robinm2
Techie
 
Posts: 11
Joined: Mon Feb 08, 2021 12:14 pm


Return to Support Forum

Who is online

Users browsing this forum: No registered users and 16 guests