How to enable "enable-media-stream" in a running CEF

Having problems with building or using CEF's C/C++ APIs? This forum is here to help. Please do not post bug reports or feature requests here.

How to enable "enable-media-stream" in a running CEF

Postby Monox18 » Sat Dec 12, 2020 5:24 pm

Hello all,

I'm developing a web application with LiveCode development tool. They integrated CEF browser in their engine. The problem is that for my application I require WebRTC which requires the "enable-media-stream" flag at the launch command. I was able to download one of the CEF sample applications, run the .exe with the flag and the WebRTC works.

But I guess LiveCode has it hard compiled into the engine. From chrome://help/ in a running CEF in the LC IDE I can see the command line used is:

Code: Select all
"C:\Program Files\RunRev\LiveCode Indy 9.6.1\LiveCode Indy.exe" --browser-subprocess-path="C:\Program Files\RunRev\LiveCode Indy 9.6.1\Externals\CEF\libbrowser-cefprocess.exe" --no-sandbox --lang=en-US --log-file="C:\Program Files\RunRev\LiveCode Indy 9.6.1\debug.log" --log-severity=disable --resources-dir-path="C:\Program Files\RunRev\LiveCode Indy 9.6.1\Externals\CEF" --locales-dir-path="C:\Program Files\RunRev\LiveCode Indy 9.6.1\Externals\CEF\locales" --disable-features=VizDisplayCompositor,NetworkService


I cannot change that command to add the flag myself. Also I filed them a bug and wrote in their forums but that might take a while. In the meanwhile I come here for a workaround. Any ideas how could I solve this problem? maybe a way of using CMD in Windows to send the flag to an already running CEF instance? or maybe configure the CEF .exe somehow to always run with that flag?
Monox18
Newbie
 
Posts: 1
Joined: Sat Dec 12, 2020 5:03 pm

Return to Support Forum

Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot] and 17 guests