branch 4389 create.bat fails

Having problems with building or using CEF's C/C++ APIs? This forum is here to help. Please do not post bug reports or feature requests here.

branch 4389 create.bat fails

Postby tokyoalex » Tue Mar 16, 2021 9:11 am

Generating CEF project files...
ERROR at //third_party/perfetto/protos/third_party/chromium/ Assignment had no effect.
exclude_imports = true
You set the variable "exclude_imports" here and it was unused before it went
out of scope.
See //third_party/perfetto/protos/third_party/chromium/ whence it was called.
perfetto_proto_library("chrome_track_event_@TYPE@") {
See //third_party/perfetto/src/trace_processor/importers/ which caused the file to be included.
deps = [ descriptor_target ]
Traceback (most recent call last):
File "tools\", line 146, in <module>
RunAction(src_dir, cmd)
File "c:\code\chromium_git\chromium\src\cef\tools\", line 36, in RunAction
command, cwd=dir, always_show_header=True, print_stdout=True)
File "C:\code\depot_tools\", line 674, in CheckCallAndFilter
rv, args, kwargs.get('cwd', None), None, None)
subprocess2.CalledProcessError: Command 'gn gen out\\Debug_GN_x86 --ide=vs2017 --sln=cef --filters=//cef/*' returned non-zero exit status 1 in c:\code\chromium_git\chromium\src

Using vs2017, win 10 64 bit, environment vars are correct, correct Win SDK installed (10.0.19041), python 2.7.17
Tried latest code and branch 4389 both fail at the same point

Ran this script direct to fix previous error

Tried commenting out exclude_imports but just get more errors.
Would anyone be so kind as help?
Posts: 1
Joined: Tue Mar 16, 2021 9:01 am

Return to Support Forum

Who is online

Users browsing this forum: No registered users and 15 guests