Page 1 of 1

Problem with --disable-site-isolation-trials

PostPosted: Mon Apr 12, 2021 10:40 am
by rado
Some time ago I had to add switch "--disable-site-isolation-trials" to my application to solve some problem with CefResourceHandler::ProcessRequest, but I don't remember what exactly was the problem so I'm not sure whether I can safely remove it.
Unfortunately I've found site containing some angular JS and google's recaptcha which does not work when the "disable-site-isolation-trials" switch is used (tested also in cefsimple). There is some error in console that recaptcha cannot find some expected object defined in window. I'm not sure whether it is problem with timing or script from one domain is trying to access window from another, it is complicated script.
Is is expected that some scripts stops working when "disable-site-isolation-trials" is used?

Re: Problem with --disable-site-isolation-trials

PostPosted: Mon Apr 12, 2021 12:20 pm
by rado
I've tried also newer version of CEF and the site didn't work even without any parameters so I went back to previous version and it stopped working no matter whether I use any arguments so it seems like it worked just once or twice by some coincidence and it has nothing to do with --disable-site-isolation-trials
Tested with

site works in chrome so I'm out of ideas

Re: Problem with --disable-site-isolation-trials

PostPosted: Mon Apr 12, 2021 12:23 pm
by magreenblatt
This might be related: viewtopic.php?f=6&t=17571

Re: Problem with --disable-site-isolation-trials

PostPosted: Mon Apr 12, 2021 1:11 pm
by rado
magreenblatt wrote:This might be related: viewtopic.php?f=6&t=17571

It does not seem so. But now I've tried the site in Chrome on MacOS [89.0.4389.82 (Official Build) (x86_64) ] and it had the same script issue like in CEF. After I've upgraded to [89.0.4389.114 (Official Build) (x86_64)] it started to work.
It could be some flawed script which was tested only on latest Chrome and Firefox.