renderer process not being terminated

Having problems with building or using CEF's C/C++ APIs? This forum is here to help. Please do not post bug reports or feature requests here.

renderer process not being terminated

Postby smayoral » Mon May 03, 2021 4:58 am

I have updated my Chromium Windows application from 79.1.38+gecefb59+chromium-79.0.3945.130 to 90.5.4+gc6a4331-90.0.4430.72 and I have now problems with renderer processes not being terminated.

With the former Chromium version 5 processes are created, main, two renderer, utility (network) and gpu processes but with the new version of Chromium an additional utility process is created (storage).

My Windows application start loading a main site through a local webserver and a number of applications are displayed like in a smartphone:

- http://localhost:server_port/main.html

All applications are loaded through the webserver: (no additional renderer processes are created)

- http://localhost:server_port/app0.html, http://localhost:server_port/app1.html, ...

These website applications can be opened inside the main window (inline) or detached from the main window and opened as PopUps (several windows). In both cases the number of renderer processes are still two.

But the problem with the new Chromium version is when I have PopUps opened and I close the application sometimes a renderer process remains.

In order to close my application I just post a WM_CLOSE to the Chromium Window:

PostMessage(hwnd, WM_CLOSE, 0, 0);

and I call CefQuitMessageLoop inside OnBeforeClose when no CefBrowser instances remain like in the cefsimple example.

Any idea where I should look into?

I could test all Chromium version between these two versions in order to find out when the problem appears for the first time but I would like to update to the newest Chromium version.

Thanks!
smayoral
Techie
 
Posts: 22
Joined: Wed Jan 10, 2018 8:58 am

Return to Support Forum

Who is online

Users browsing this forum: Google [Bot], kikiako and 16 guests