GetAuthCredentials is not called

Having problems with building or using CEF's C/C++ APIs? This forum is here to help. Please do not post bug reports or feature requests here.

GetAuthCredentials is not called

Postby naoki5 » Wed May 12, 2021 12:43 am

CefRequestHandler::GetAuthCredentials may not be called.

https://allabout.co.jp/gm/gc/23780/
The above page is an article that explains Basic authentication.
GetAuthCredentials is not called when I open the link to the sample page in the middle of the page.

It is not called in CEF 90.6.5, but it is called successfully in CEF 89.0.17.
I can reproduce this issue too with cefclient.

The above link seems to be redirecting to the sample page.
It was fine if I opened the sample page directly.


Windows 10 Pro 64bit 20H2 (Japanese)
Visual Studio 2017 Version 15.9.35
naoki5
Mentor
 
Posts: 52
Joined: Wed Jul 17, 2019 2:44 am

Re: GetAuthCredentials is not called

Postby magreenblatt » Wed May 12, 2021 9:01 am

How does it behave with Google Chrome at the same version? Does it show the auth dialog?
magreenblatt
Site Admin
 
Posts: 10939
Joined: Fri May 29, 2009 6:57 pm

Re: GetAuthCredentials is not called

Postby naoki5 » Thu May 13, 2021 2:38 am

magreenblatt wrote:How does it behave with Google Chrome at the same version? Does it show the auth dialog?


It's not the same version, but I tried it on Google Chrome 90.0.4430.212 (32bit) .
The auth dialog is displayed and it works normally.

This issue occurred with the cefclient included in CEF 90.6.5 (Windows 32-bit).
The same is true for my application that incorporates this CEF.
naoki5
Mentor
 
Posts: 52
Joined: Wed Jul 17, 2019 2:44 am

Re: GetAuthCredentials is not called

Postby magreenblatt » Thu May 13, 2021 9:13 am

Ok, please file a bug for the behavior change.
magreenblatt
Site Admin
 
Posts: 10939
Joined: Fri May 29, 2009 6:57 pm

Re: GetAuthCredentials is not called

Postby naoki5 » Thu May 13, 2021 11:32 pm

https://bitbucket.org/chromiumembedded/ ... entials-is

I created an issue.
I am new to creating issues, so please point me out if anything goes wrong.
naoki5
Mentor
 
Posts: 52
Joined: Wed Jul 17, 2019 2:44 am

Re: GetAuthCredentials is not called

Postby magreenblatt » Fri May 14, 2021 8:53 am

Looks good, thanks :)
magreenblatt
Site Admin
 
Posts: 10939
Joined: Fri May 29, 2009 6:57 pm


Return to Support Forum

Who is online

Users browsing this forum: No registered users and 20 guests