macOS - screen capture has frozen frame, but moving cursor

Having problems with building or using CEF's C/C++ APIs? This forum is here to help. Please do not post bug reports or feature requests here.

macOS - screen capture has frozen frame, but moving cursor

Postby glmdev » Fri May 28, 2021 10:16 am

Hello -

I'm trying to use WebRTC for screen capture on macOS. I've provided details below about particular versions.

- CEF binary 3.3987.163 (I've tried with up to CEF based on chromium 90 with the same result)
- macOS Big Sur 11.3

Thanks to some other helpful forum topics, I've configured CEF to allow screen recording using "enable-media-stream", "enable-usermedia-screen-capturing", and "use-fake-ui-for-media-stream" command line switches.

During the application startup, I am also performing CGRequestScreenCaptureAccess() which appears to be succeeding, and the application is listed in the screen recording permissions page in system preferences.

Within the app running in CEF, I am able to get a stream object of the screen using navigator.mediaDevices.getDisplayMedia({video: true}) with no errors. The issue comes in the files created from this stream.

When playing back the screen capture video, I noticed that the frame of the screen is frozen at the point it was when we called getDisplayMedia. However, perplexingly, the mouse still visibly moves around the screen despite the actual frame not changing.

I've tried swapping this for getUserMedia with the "screen" source, but this produces the same result.

I'm curious if anyone else has encountered this before, or has suggestions on how to further debug this issue. Thanks in advance.
Posts: 1
Joined: Fri May 28, 2021 9:41 am

Return to Support Forum

Who is online

Users browsing this forum: Google [Bot] and 18 guests