CEF app launch failure with MacOS 10.10

Having problems with building or using CEF's C/C++ APIs? This forum is here to help. Please do not post bug reports or feature requests here.

CEF app launch failure with MacOS 10.10

Postby Satrajit » Wed Jun 09, 2021 4:07 am

with CEF 4430 the app is failing to launch with MacOS 10.10 (Yosemite) with the error Symbol not found: ___NSArray0__
Changed the CEF_TARGET_SDK in cef_variables.cmake.in to 10.10 but still doesn't work

what other changes do I need to make to work for Yosemite ?
Satrajit
Mentor
 
Posts: 73
Joined: Wed Jan 09, 2019 6:11 am

Re: CEF app launch failure with MacOS 10.10

Postby ndesktop » Wed Jun 09, 2021 9:03 am

Not building frequently on Mac, but requirements for 4430 says:
macOS 10.11+ deployment, 10.15.4+ build system w/ 11.0 base SDK (Xcode 12.2), Ninja, 64-bit only
Maybe 10.10 is not anymore supported? 4280 seems to be the latest to support 10.10.

Or CoreFoundation.framework is missing.
ndesktop
Master
 
Posts: 558
Joined: Thu Dec 03, 2015 10:10 am

Re: CEF app launch failure with MacOS 10.10

Postby Satrajit » Wed Jun 09, 2021 9:38 am

Yes I saw the requirements.

But is it somehow possible/ or not possible at all to support 10.10 by making few tweaks locally ?
Satrajit
Mentor
 
Posts: 73
Joined: Wed Jan 09, 2019 6:11 am

Re: CEF app launch failure with MacOS 10.10

Postby magreenblatt » Wed Jun 09, 2021 9:50 am

Satrajit wrote:Yes I saw the requirements.

But is it somehow possible/ or not possible at all to support 10.10 by making few tweaks locally ?

Not possible without substantial work. 10.10 support was deleted from Chromium.
magreenblatt
Site Admin
 
Posts: 10947
Joined: Fri May 29, 2009 6:57 pm


Return to Support Forum

Who is online

Users browsing this forum: Google [Bot] and 13 guests