[solved]Failed to build legacy release version

Having problems with building or using CEF's C/C++ APIs? This forum is here to help. Please do not post bug reports or feature requests here.

[solved]Failed to build legacy release version

Postby tiplip » Tue Jun 22, 2021 8:16 pm

Hi

From Legacy Release Branches (Unsupported)
I download Cef3.4389 and chromium-89.0.4389.114.tar.xz

then combine them as below after unzip
Code: Select all
--C:\code
      |--automate
      |--chromium_git
      |       |--chromium
      |                |--src
      |                     |--<chromium source code>
      |                     |--cef
      |                     |--<chromium source code>
      |--depot_tools


Environment
Windows 10 home edition
DEPOT_TOOLS_WIN_TOOLCHAIN=0
GYP_MSVS_VERSION=2019
GYP_MSVS_OVERRIDE_PATH=C:\Program Files (x86)\Microsoft Visual Studio\2019\Community


error
Code: Select all
C:\Users\tipli>cd C:\code\chromium_git\chromium\src\cef

C:\code\chromium_git\chromium\src\cef>create.bat

C:\code\chromium_git\chromium\src\cef>set GN_DEFINES=is_component_build=true

C:\code\chromium_git\chromium\src\cef>set GN_ARGUMENTS=--ide=vs2019 --sln=cef --filters=//cef/*

C:\code\chromium_git\chromium\src\cef>call cef_create_projects.bat

Generating CEF version header file...

Patching build configuration and source files for CEF...

Apply gritsettings.patch in C:\code\chromium_git\chromium\src
... patch directory is not a repository root.
-------------------------------------------------------------------------------
!!!! ERROR: This patch failed to apply. Your build will not be correct.
-------------------------------------------------------------------------------

Traceback (most recent call last):
  File "tools\gclient_hook.py", line 37, in <module>
    RunAction(cef_dir, cmd)
  File "C:\code\chromium_git\chromium\src\cef\tools\gclient_util.py", line 36, in RunAction
    command, cwd=dir, always_show_header=True, print_stdout=True)
  File "c:\code\depot_tools\gclient_utils.py", line 674, in CheckCallAndFilter
    rv, args, kwargs.get('cwd', None), None, None)
subprocess2.CalledProcessError: Command 'c:\\code\\depot_tools\\bootstrap-2@3_8_10_chromium_17_bin\\python\\bin\\python.exe tools/patcher.py' returned non-zero exit status 1 in C:\code\chromium_git\chromium\src\cef


my question is, what do I miss? are there any detailed instructions to follow?

thanks
Last edited by tiplip on Thu Jun 24, 2021 11:08 pm, edited 1 time in total.
tiplip
Mentor
 
Posts: 64
Joined: Thu Mar 26, 2015 3:09 am

Re: Failed to build legacy release version

Postby magreenblatt » Tue Jun 22, 2021 9:56 pm

Version 89 isn’t that old. It will probably work to build in the usual way.
magreenblatt
Site Admin
 
Posts: 10927
Joined: Fri May 29, 2009 6:57 pm

Re: Failed to build legacy release version

Postby tiplip » Tue Jun 22, 2021 10:43 pm

thanks for your quick reply.

But the fact is that my connection is bad, and often fail to sync and I have to start from scratch again and again, so turn to legacy way.
for 89, it does not apply?
tiplip
Mentor
 
Posts: 64
Joined: Thu Mar 26, 2015 3:09 am

Re: Failed to build legacy release version

Postby magreenblatt » Wed Jun 23, 2021 9:48 am

The legacy way is not something that we test or support. It looks like your CEF and Chromium versions don’t match, or the patches are failing to apply for some other reason. Did you run “gclient runhooks” after assembling the directory structure?
magreenblatt
Site Admin
 
Posts: 10927
Joined: Fri May 29, 2009 6:57 pm

Re: Failed to build legacy release version

Postby magreenblatt » Wed Jun 23, 2021 9:52 am

C:\code\chromium_git\chromium\src
... patch directory is not a repository root.

You’ll need to fix the scripts to work without a valid Git checkout.
magreenblatt
Site Admin
 
Posts: 10927
Joined: Fri May 29, 2009 6:57 pm

Re: Failed to build legacy release version

Postby tiplip » Wed Jun 23, 2021 7:00 pm

magreenblatt wrote:The legacy way is not something that we test or support. It looks like your CEF and Chromium versions don’t match, or the patches are failing to apply for some other reason. Did you run “gclient runhooks” after assembling the directory structure?


thanks, I run the command you metioned, but prompt error as below after sometime later, now googling for the answer, not found yet
Code: Select all
C:\code\chromium_git\chromium\src>gclient runhooks
Running hooks:  22% (22/97) lastchange
________ running 'vpython.bat src/build/util/lastchange.py -o src/build/util/LASTCHANGE' in 'C:\code\chromium_git\chromium'
ERROR:root:Failed to get git top directory from 'C:\code\chromium_git\chromium\src\build\util': Git command 'git rev-parse --show-toplevel' in C:\code\chromium_git\chromium\src\build\util failed: rc=128, stdout='' stderr='fatal: not a git repository (or any of the parent directories): .git
'
Error: Command 'vpython.bat src/build/util/lastchange.py -o src/build/util/LASTCHANGE' returned non-zero exit status 2 in C:\code\chromium_git\chromium




maybe I should check the script, for my understanding, it worked normally with right folder structure after 'gclient runhooks'
tiplip
Mentor
 
Posts: 64
Joined: Thu Mar 26, 2015 3:09 am

Re: [solved]Failed to build legacy release version

Postby tiplip » Thu Jun 24, 2021 11:09 pm

gclient runhooks works
tiplip
Mentor
 
Posts: 64
Joined: Thu Mar 26, 2015 3:09 am


Return to Support Forum

Who is online

Users browsing this forum: Google [Bot] and 25 guests