VS solution build fails (GetJNIEnv: identifier not found)

Having problems with building or using the JCEF Java binding? Ask your questions here.

VS solution build fails (GetJNIEnv: identifier not found)

Postby pfrigge » Mon Nov 23, 2020 4:15 am

Hi,
I'm trying to build jcef on windows using Visual Studio 2019. When building the solution the project "jcef" fails with error in request_handler.cpp (line 67): error C3861: 'GetJNIEnv': identifier not found.

Any idea what I've done wrong or could try?
Here are some additional information that may or may not help:
I'm following the guide at https://bitbucket.org/chromiumembedded/java-cef/wiki/BranchesAndBuilding but am using Visual Studio 2019. I used the following cmake command which seemed to work fine:
Code: Select all
cmake -G "Visual Studio 16" ..

When I open the solution a warning is shown: "The 'IntelliCodeCppPackage' package did not load correctly. The problem may have been caused by a configuration change or by the installation of another extension. You can get more information by examining the file 'C:\Users\[username]\AppData\Roaming\Microsoft\VisualStudio\16.0_bdf58501\ActivityLog.xml'. Restarting Visual Studio could help resolve this issue."

Before that i tried using Visual Studio 2013 but had the same error.

Thanks in advance for your help!
pfrigge
Newbie
 
Posts: 2
Joined: Mon Nov 23, 2020 3:23 am

Re: VS solution build fails (GetJNIEnv: identifier not found

Postby magreenblatt » Mon Nov 23, 2020 12:18 pm

magreenblatt
Site Admin
 
Posts: 11088
Joined: Fri May 29, 2009 6:57 pm


Return to JCEF Forum

Who is online

Users browsing this forum: No registered users and 1 guest