cefclient OSR and multi-threaded-message-loop

Having problems with building or using CEF's C/C++ APIs? This forum is here to help. Please do not post bug reports or feature requests here.

cefclient OSR and multi-threaded-message-loop

Postby ejorge » Mon Apr 26, 2021 5:47 am

Hello there (and, we do not say it enough, but, thank you for your great work)
From CEF-89, I got an issue using with OSR mode.
1 - Steps to reproduce:
-- Launch ./cefclient --offscreen-rendering-enabled
-- https://www.google.com is loaded
-- From the address bar, copy (using ctrl+c) the url or some word of the url (e.g: google)
-- Paste the related text (using ctrl+v) in an input field into the webview (e.g: google.com search field)

2 - Expected output: the text may be pasted
Instead, the entire application freezes, then after exactly 30 sec, the application comes back to life but the copied word is not pasted

3 - Tested version : CEF 90 (https://cef-builds.spotifycdn.com/cef_b ... 64.tar.bz2) built and run from Ubuntu 18.04 64 bits
The issue seems to have been introduced from CEF 89. I could not reproduce it using CEF 88.
I tried to look for commits related to OSR between CEF-88 (4324)/CEF-89 (4389) i.e: c761b1e8c, c02bfc66c, c1f90d8c9, 0ee212251.
The last one refers to #3087
and I tried using: ./cefclient --offscreen-rendering-enabled --multi-threaded-message-loop
Then it works! but, why with those flags combination?
Do offscreen-rendering need multi-threaded-message-loop from CEF-89?
Thanks for your expertise!
Posts: 4
Joined: Fri Nov 29, 2019 9:49 am

Re: cefclient OSR and multi-threaded-message-loop

Postby salvadordf » Mon Apr 26, 2021 7:43 am

I can reproduce this issue too with the latest cefclient.
I also tried the CEF4Delphi demos on Linux and they have the same issue.

Edit: One CPU core uses 100% when pasting the text.
Maintainer of the CEF4Delphi project.
User avatar
Posts: 112
Joined: Sun Dec 18, 2016 8:39 am
Location: Spain

Re: cefclient OSR and multi-threaded-message-loop

Postby magreenblatt » Mon Apr 26, 2021 9:39 am

Sounds like a bug. Please file an issue for it.
Site Admin
Posts: 11083
Joined: Fri May 29, 2009 6:57 pm

Return to Support Forum

Who is online

Users browsing this forum: Google [Bot] and 29 guests